Tested on a lsb images which enabled pam for crond. Non-root user can't perform command 'crontab -l/-e'. The error logs from /var/log/auth.log: Jul 12 02:36:14 qemux86 unix_chkpwd[768]: could not obtain user info (test-pam) root cause: unix_chkpwd can't get user info from '/etc/shadow' because it has incorrect permission settings: root@qemux86:~# ll /etc/shadow -r-------- 1 root root 1090 Jul 14 05:29 /etc/shadow On a ubuntu host it is: -rw-r----- 1 root shadow 1389 2011-07-07 18:04 /etc/shadow
*** Bug 1253 has been marked as a duplicate of this bug. ***
May require setting setuid bit for non-pam crontab binary
Merged
The commit 6ba3b6ba9b8587791e392bf3542403ab33ca9ad3
Verified with poky master branch. git info: 6c2b7beac3cd23ed44bd3e195c6360a0932876bf